What’s Vulnerable › Vulnerabilities
CVE-2019-7397
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-02-05 · updated 2026-06-17
- Weakness: CWE-401
Description
In ImageMagick before 7.0.8-25 and GraphicsMagick through 1.3.31, several memory leaks exist in WritePDFImage in coders/pdf.c.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 18.10, 19.04
- Debian Linux: 10.0
- GraphicsMagick: through 1.3.31
- ImageMagick: before 6.9.10-25; from 7.0.0-0 before 7.0.8-25 — fixed in 6.9.10-25, 7.0.8-25
- openSUSE Leap: 15.0
How to fix
Upgrade to a fixed version: ImageMagick 6.9.10-25, 7.0.8-25. Check the vendor advisory for mitigations.
References
- http://hg.graphicsmagick.org/hg/GraphicsMagick/rev/11ad3aeb8ab1
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00034.html
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00006.html
- http://www.securityfocus.com/bid/106847
- https://github.com/ImageMagick/ImageMagick/commit/306c1f0fa5754ca78efd16ab752f0e981d4f6b82
- https://github.com/ImageMagick/ImageMagick/issues/1454
- https://usn.ubuntu.com/4034-1/
- https://www.debian.org/security/2020/dsa-4712
- http://hg.graphicsmagick.org/hg/GraphicsMagick/rev/11ad3aeb8ab1
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00034.html
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00006.html
- http://www.securityfocus.com/bid/106847
Get alerted when CVE-2019-7397 or the next vulnerability affects your stack