What’s Vulnerable › Vulnerabilities
CVE-2019-7398
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-02-05 · updated 2026-06-17
- Weakness: CWE-401
Description
In ImageMagick before 7.0.8-25, a memory leak exists in WriteDIBImage in coders/dib.c.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 18.10, 19.04
- Debian Linux: 10.0
- ImageMagick: before 6.9.10-25; from 7.0.0-0 before 7.0.8-25 — fixed in 6.9.10-25, 7.0.8-25
- openSUSE Leap: 15.0
How to fix
Upgrade to a fixed version: ImageMagick 6.9.10-25, 7.0.8-25. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00034.html
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00006.html
- http://www.securityfocus.com/bid/106848
- https://github.com/ImageMagick/ImageMagick/issues/1453
- https://usn.ubuntu.com/4034-1/
- https://www.debian.org/security/2020/dsa-4712
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00034.html
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00006.html
- http://www.securityfocus.com/bid/106848
- https://github.com/ImageMagick/ImageMagick/issues/1453
- https://usn.ubuntu.com/4034-1/
- https://www.debian.org/security/2020/dsa-4712
Get alerted when CVE-2019-7398 or the next vulnerability affects your stack