What’s Vulnerable › Vulnerabilities
CVE-2019-7401
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-02-08 · updated 2026-06-17
- Weakness: CWE-787
Description
NGINX Unit before 1.7.1 might allow an attacker to cause a heap-based buffer overflow in the router process with a specially crafted request. This may result in a denial of service (router process crash) or possibly have unspecified other impact.
Affected products
- F5 NGINX Unit: from 0.3 before 1.7.1 — fixed in 1.7.1
How to fix
Upgrade to a fixed version: F5 NGINX Unit 1.7.1. Check the vendor advisory for mitigations.
References
- http://hg.nginx.org/unit/file/tip/CHANGES
- http://mailman.nginx.org/pipermail/unit/2019-February/000113.html
- http://unit.nginx.org/CHANGES.txt
- http://www.securityfocus.com/bid/106956
- http://hg.nginx.org/unit/file/tip/CHANGES
- http://mailman.nginx.org/pipermail/unit/2019-February/000113.html
- http://unit.nginx.org/CHANGES.txt
- http://www.securityfocus.com/bid/106956
Get alerted when CVE-2019-7401 or the next vulnerability affects your stack