What’s Vulnerable › Vulnerabilities
CVE-2019-7524
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-28 · updated 2026-06-17
- Weakness: CWE-119
Description
In Dovecot before 2.2.36.3 and 2.3.x before 2.3.5.1, a local attacker can cause a buffer overflow in the indexer-worker process, which can be used to elevate to root. This occurs because of missing checks in the fts and pop3-uidl components.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Debian Linux: 8.0, 9.0
- dovecot: before 2.2.36.3; from 2.3.0 before 2.3.5.1 — fixed in 2.2.36.3, 2.3.5.1
- openSUSE Leap: 15.0, 42.3
How to fix
Upgrade to a fixed version: dovecot 2.2.36.3, 2.3.5.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00060.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00067.html
- http://www.openwall.com/lists/oss-security/2019/03/28/1
- http://www.securityfocus.com/bid/107672
- https://dovecot.org/list/dovecot-news/2019-March/000403.html
- https://dovecot.org/security.html
- https://lists.debian.org/debian-lts-announce/2019/03/msg00038.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4XLI55NGRDTGMVOPYFCPPFNPA5VKYSSY/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QHFZ5OWRIZGIWZJ5PTNVWWZNLLNH4XYS/
- https://seclists.org/bugtraq/2019/Mar/59
- https://security.gentoo.org/glsa/201904-19
- https://usn.ubuntu.com/3928-1/
Get alerted when CVE-2019-7524 or the next vulnerability affects your stack