What’s Vulnerable › Vulnerabilities
CVE-2019-7589: Kantech EntraPass Improper Input Validation
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-10 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability with the SmartService API Service option exists whereby an unauthorized user could potentially exploit this to upload malicious code to the server that could be executed at system level privileges. This affects Johnson Controls' Kantech EntraPass Corporate Edition versions 8.0 and prior; Kantech EntraPass Global Edition versions 8.0 and prior.
Affected products
- Johnsoncontrols Entrapass: before 8.10 — fixed in 8.10
How to fix
Upgrade to a fixed version: Johnsoncontrols Entrapass 8.10. Check the vendor advisory for mitigations.
References
- https://www.johnsoncontrols.com/cyber-solutions/security-advisories
- https://www.us-cert.gov/ics/advisories/icsa-20-070-04
- https://www.johnsoncontrols.com/cyber-solutions/security-advisories
- https://www.us-cert.gov/ics/advisories/icsa-20-070-04
Get alerted when CVE-2019-7589 or the next vulnerability affects your stack