What’s Vulnerable › Vulnerabilities
CVE-2019-7612
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-25 · updated 2026-06-17
- Weakness: CWE-209
Description
A sensitive data disclosure flaw was found in the way Logstash versions before 5.6.15 and 6.6.1 logs malformed URLs. If a malformed URL is specified as part of the Logstash configuration, the credentials for the URL could be inadvertently logged as part of the error message.
Affected products
- Elastic Logstash: before 5.6.15; from 6.0.0 before 6.6.1 — fixed in 5.6.15, 6.6.1
- NetApp Active Iq Performance Analytics Services: all versions
How to fix
Upgrade to a fixed version: Elastic Logstash 5.6.15, 6.6.1. Check the vendor advisory for mitigations.
References
- https://discuss.elastic.co/t/elastic-stack-6-6-1-and-5-6-15-security-update/169077
- https://security.netapp.com/advisory/ntap-20190411-0002/
- https://www.elastic.co/community/security
- https://discuss.elastic.co/t/elastic-stack-6-6-1-and-5-6-15-security-update/169077
- https://security.netapp.com/advisory/ntap-20190411-0002/
- https://www.elastic.co/community/security
Get alerted when CVE-2019-7612 or the next vulnerability affects your stack