What’s Vulnerable › Vulnerabilities
CVE-2019-7614
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-30 · updated 2026-06-17
- Weakness: CWE-362
Description
A race condition flaw was found in the response headers Elasticsearch versions before 7.2.1 and 6.8.2 returns to a request. On a system with multiple users submitting requests, it could be possible for an attacker to gain access to response header containing sensitive data from another user.
Affected products
- Elasticsearch: before 6.8.2; from 7.0.0 before 7.2.1 — fixed in 6.8.2, 7.2.1
How to fix
Upgrade to a fixed version: Elasticsearch 6.8.2, 7.2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-7614 or the next vulnerability affects your stack