What’s Vulnerable › Vulnerabilities
CVE-2019-7615
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-30 · updated 2026-06-17
- Weakness: CWE-295
Description
A TLS certificate validation flaw was found in Elastic APM agent for Ruby versions before 2.9.0. When specifying a trusted server CA certificate via the 'server_ca_cert' setting, the Ruby agent would not properly verify the certificate returned by the APM server. This could result in a man in the middle style attack against the Ruby agent.
Affected products
- Elastic APM agent for Ruby: before 2.9.0 — fixed in 2.9.0
How to fix
Upgrade to a fixed version: Elastic APM agent for Ruby 2.9.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-7615 or the next vulnerability affects your stack