What’s Vulnerable › Vulnerabilities
CVE-2019-7620
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-30 · updated 2026-06-17
- Weakness: CWE-400
Description
Logstash versions before 7.4.1 and 6.8.4 contain a denial of service flaw in the Logstash Beats input plugin. An unauthenticated user who is able to connect to the port the Logstash beats input could send a specially crafted network packet that would cause Logstash to stop responding.
Affected products
- Elastic Logstash: from 6.0.0 before 6.8.4; from 7.0.0 before 7.4.1 — fixed in 6.8.4, 7.4.1
How to fix
Upgrade to a fixed version: Elastic Logstash 6.8.4, 7.4.1. Check the vendor advisory for mitigations.
References
- https://discuss.elastic.co/t/elastic-stack-6-8-4-security-update/204908
- https://discuss.elastic.co/t/elastic-stack-7-4-1-security-update/204909
- https://www.elastic.co/community/security
- https://discuss.elastic.co/t/elastic-stack-6-8-4-security-update/204908
- https://discuss.elastic.co/t/elastic-stack-7-4-1-security-update/204909
- https://www.elastic.co/community/security
Get alerted when CVE-2019-7620 or the next vulnerability affects your stack