What’s Vulnerable › Vulnerabilities
CVE-2019-7621
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Kibana versions before 6.8.6 and 7.5.1 contain a cross site scripting (XSS) flaw in the coordinate and region map visualizations. An attacker with the ability to create coordinate map visualizations could create a malicious visualization. If another Kibana user views that visualization or a dashboard containing the visualization it could execute JavaScript in the victim�s browser.
Affected products
- Kibana: before 6.8.6; from 7.0.0 before 7.5.1 — fixed in 6.8.6, 7.5.1
How to fix
Upgrade to a fixed version: Kibana 6.8.6, 7.5.1. Check the vendor advisory for mitigations.
References
- https://discuss.elastic.co/t/elastic-stack-6-8-6-and-7-5-1-security-update/212390
- https://www.elastic.co/community/security/
- https://discuss.elastic.co/t/elastic-stack-6-8-6-and-7-5-1-security-update/212390
- https://www.elastic.co/community/security/
Get alerted when CVE-2019-7621 or the next vulnerability affects your stack