What’s Vulnerable › Vulnerabilities
CVE-2019-7644
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-11 · updated 2026-06-17
- Weakness: CWE-209
Description
Auth0 Auth0-WCF-Service-JWT before 1.0.4 leaks the expected JWT signature in an error message when it cannot successfully validate the JWT signature. If this error message is presented to an attacker, they can forge an arbitrary JWT token that will be accepted by the vulnerable application.
Affected products
- Auth0-Wcf-Service-Jwt: before 1.0.4 — fixed in 1.0.4
How to fix
Upgrade to a fixed version: Auth0-Wcf-Service-Jwt 1.0.4. Check the vendor advisory for mitigations.
References
- https://auth0.com/docs/security/bulletins/cve-2019-7644
- https://auth0.com/docs/security/bulletins/cve-2019-7644
Get alerted when CVE-2019-7644 or the next vulnerability affects your stack