What’s Vulnerable › Vulnerabilities
CVE-2019-7659
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-02-09 · updated 2026-06-17
- Weakness: CWE-787
Description
Genivia gSOAP 2.7.x and 2.8.x before 2.8.75 allows attackers to cause a denial of service (application abort) or possibly have unspecified other impact if a server application is built with the -DWITH_COOKIES flag. This affects the C/C++ libgsoapck/libgsoapck++ and libgsoapssl/libgsoapssl++ libraries, as these are built with that flag.
Affected products
- Debian Linux: 8.0
- Genivia gSOAP: from 2.7.0 through 2.7.17; from 2.8.0 before 2.8.75 — fixed in 2.8.75
How to fix
Upgrade to a fixed version: Genivia gSOAP 2.8.75. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2019/02/msg00027.html
- https://outpost24.com/blog/gsoap-vulnerability-identified
- https://www.genivia.com/advisory.html#Bug_in_gSOAP_versions_2.7.0_to_2.8.74_for_applications_built_with_the_WITH_COOKIES_flag_enabled_%28Jan_14%2C_2019%29
- https://lists.debian.org/debian-lts-announce/2019/02/msg00027.html
- https://outpost24.com/blog/gsoap-vulnerability-identified
- https://www.genivia.com/advisory.html#Bug_in_gSOAP_versions_2.7.0_to_2.8.74_for_applications_built_with_the_WITH_COOKIES_flag_enabled_%28Jan_14%2C_2019%29
Get alerted when CVE-2019-7659 or the next vulnerability affects your stack