What’s Vulnerable › Vulnerabilities
CVE-2019-7849
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-02 · updated 2026-06-17
- Weakness: CWE-384
Description
A defense-in-depth check was added to mitigate inadequate session validation handling by 3rd party checkout modules. This impacts Magento 1.x prior to 1.9.4.2, Magento Commerce prior to 1.14.4.2, Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9 and Magento 2.3 prior to 2.3.2.
Affected products
- Adobe Magento Commerce: before 1.14.4.2; from 1.0.0 before 1.9.4.2; from 2.1.0 before 2.1.18; from 2.2.0 before 2.2.9; from 2.3.0 before 2.3.2 — fixed in 1.14.4.2, 1.9.4.2, 2.1.18, 2.2.9, 2.3.2
How to fix
Upgrade to a fixed version: Adobe Magento Commerce 1.14.4.2, 1.9.4.2, 2.1.18, 2.2.9. Check the vendor advisory for mitigations.
References
- https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-33
- https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-33
Get alerted when CVE-2019-7849 or the next vulnerability affects your stack