What’s Vulnerable › Vulnerabilities
CVE-2019-7869
- Severity: medium (CVSS 4.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-02 · updated 2026-06-17
- Weakness: CWE-79
Description
A stored cross-site scripting vulnerability exists in the admin panel of Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This can be exploited by an authenticated user with permissions to manage customer groups.
Affected products
- Adobe Magento Commerce: from 2.1.0 before 2.1.18; from 2.2.0 before 2.2.9; from 2.3.0 before 2.3.2 — fixed in 2.1.18, 2.2.9, 2.3.2
How to fix
Upgrade to a fixed version: Adobe Magento Commerce 2.1.18, 2.2.9, 2.3.2. Check the vendor advisory for mitigations.
References
- https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-23
- https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-23
Get alerted when CVE-2019-7869 or the next vulnerability affects your stack