What’s Vulnerable › Vulnerabilities
CVE-2019-7888
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-02 · updated 2026-06-17
Description
An information disclosure vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An authenticated user with privileges to create email templates could leak sensitive data via a malicious email template.
Affected products
- Adobe Magento Commerce: from 2.1.0 before 2.1.18; from 2.2.0 before 2.2.9; from 2.3.0 before 2.3.2 — fixed in 2.1.18, 2.2.9, 2.3.2
How to fix
Upgrade to a fixed version: Adobe Magento Commerce 2.1.18, 2.2.9, 2.3.2. Check the vendor advisory for mitigations.
References
- https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-33
- https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-33
Get alerted when CVE-2019-7888 or the next vulnerability affects your stack