What’s Vulnerable › Vulnerabilities

CVE-2019-7895

Description

A remote code execution vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An authenticated user with admin privileges to layouts can execute arbitrary code through a crafted XML layout update.

Affected products

How to fix

Upgrade to a fixed version: Adobe Magento Commerce 2.1.18, 2.2.9, 2.3.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-7895 or the next vulnerability affects your stack