What’s Vulnerable › Vulnerabilities

CVE-2019-7932

Description

A remote code execution vulnerability exists in Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2, Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An authenticated user with admin privileges to create sitemaps can execute arbitrary PHP code by creating a malicious sitemap file.

Affected products

How to fix

Upgrade to a fixed version: Adobe Magento Commerce 1.14.4.2, 1.9.4.2, 2.1.18, 2.2.9. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-7932 or the next vulnerability affects your stack