What’s Vulnerable › Vulnerabilities
CVE-2019-8090
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-05 · updated 2026-06-17
Description
An arbitrary file deletion vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. An authenticated users can manipulate the design layout update feature.
Affected products
- Adobe Magento Commerce: from 2.1.0 before 2.1.19; from 2.2.0 before 2.2.10; from 2.3.0 before 2.3.2; 2.3.2 — fixed in 2.1.19, 2.2.10, 2.3.2
How to fix
Upgrade to a fixed version: Adobe Magento Commerce 2.1.19, 2.2.10, 2.3.2. Check the vendor advisory for mitigations.
References
- https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update
- https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update
Get alerted when CVE-2019-8090 or the next vulnerability affects your stack