What’s Vulnerable › Vulnerabilities
CVE-2019-8151
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-06 · updated 2026-06-17
- Weakness: CWE-918
Description
A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with admin privileges to manipulate shippment settings can execute arbitrary code through server-side request forgery due to unsafe handling of a carrier gateway.
Affected products
- Adobe Magento Commerce: from 2.2.0 before 2.2.10; from 2.3.0 before 2.3.2; 2.3.2 — fixed in 2.2.10, 2.3.2
How to fix
Upgrade to a fixed version: Adobe Magento Commerce 2.2.10, 2.3.2. Check the vendor advisory for mitigations.
References
- https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update
- https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update
Get alerted when CVE-2019-8151 or the next vulnerability affects your stack