What’s Vulnerable › Vulnerabilities

CVE-2019-8152

Description

A stored cross-site scripting (XSS) vulnerability exists in in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with access to the wysiwyg editor can abuse the blockDirective() function and inject malicious javascript in the cache of the admin dashboard.

Affected products

How to fix

Upgrade to a fixed version: Adobe Magento Commerce 1.14.4.3, 1.9.4.3, 2.2.10, 2.3.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-8152 or the next vulnerability affects your stack