What’s Vulnerable › Vulnerabilities
CVE-2019-8155
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-06 · updated 2026-06-17
- Weakness: CWE-352
Description
Magento prior to 1.9.4.3 and prior to 1.14.4.3 included a user's CSRF token in the URL of a GET request. This could be exploited by an attacker with access to network traffic to perform unauthorized actions.
Affected products
- Adobe Magento Commerce: from 1.5.0.0 before 1.9.4.3; from 1.9.0.0 before 1.14.4.3 — fixed in 1.14.4.3, 1.9.4.3
How to fix
Upgrade to a fixed version: Adobe Magento Commerce 1.14.4.3, 1.9.4.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-8155 or the next vulnerability affects your stack