What’s Vulnerable › Vulnerabilities
CVE-2019-8228
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-06 · updated 2026-06-17
- Weakness: CWE-79
Description
in Magento prior to 1.9.4.3 and Magento prior to 1.14.4.3, an authenticated user with limited administrative privileges can inject arbitrary JavaScript code into transactional email page when creating a new email template or editing existing email template.
Affected products
- Adobe Magento Commerce: from 1.5.0.0 before 1.9.4.3; from 1.9.0.0 before 1.14.4.3 — fixed in 1.14.4.3, 1.9.4.3
How to fix
Upgrade to a fixed version: Adobe Magento Commerce 1.14.4.3, 1.9.4.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-8228 or the next vulnerability affects your stack