What’s Vulnerable › Vulnerabilities
CVE-2019-8232
- Severity: medium (CVSS 6.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-06 · updated 2026-06-17
- Weakness: CWE-362
Description
In Magento prior to 1.9.4.3, Magento prior to 1.14.4.3, Magento 2.2 prior to 2.2.10, and Magento 2.3 prior to 2.3.3 or 2.3.2-p1, an authenticated user with administrative privileges for the import feature can execute arbitrary code through a race condition that allows webserver configuration file modification.
Affected products
- Adobe Magento Commerce: from 1.5.0.0 before 1.9.4.3; from 1.9.0.0 before 1.14.4.3; from 2.2.0 before 2.2.10; from 2.3.0 before 2.3.2; 2.3.2 — fixed in 1.14.4.3, 1.9.4.3, 2.2.10, 2.3.2
How to fix
Upgrade to a fixed version: Adobe Magento Commerce 1.14.4.3, 1.9.4.3, 2.2.10, 2.3.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-8232 or the next vulnerability affects your stack