What’s Vulnerable › Vulnerabilities
CVE-2019-8248
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-14 · updated 2026-06-17
- Weakness: CWE-787
Description
Adobe Illustrator CC versions 23.1 and earlier have a memory corruption vulnerability. Successful exploitation could lead to arbitrary code execution .
Affected products
- Adobe Illustrator CC: before 24.0 — fixed in 24.0
How to fix
Upgrade to a fixed version: Adobe Illustrator CC 24.0. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/illustrator/apsb19-36.html
- https://helpx.adobe.com/security/products/illustrator/apsb19-36.html
Get alerted when CVE-2019-8248 or the next vulnerability affects your stack