What’s Vulnerable › Vulnerabilities
CVE-2019-8308
- Severity: high (CVSS 8.2 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-02-12 · updated 2026-06-17
- Weakness: CWE-668
Description
Flatpak before 1.0.7, and 1.1.x and 1.2.x before 1.2.3, exposes /proc in the apply_extra script sandbox, which allows attackers to modify a host-side executable file.
Affected products
- Debian Linux: 9.0, 10.0
- flatpak: before 1.0.7; from 1.1.0 through 1.1.3; from 1.2.0 through 1.2.3 — fixed in 1.0.7
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: flatpak 1.0.7. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00088.html
- https://access.redhat.com/errata/RHSA-2019:0375
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=922059
- https://github.com/flatpak/flatpak/releases/tag/1.0.7
- https://github.com/flatpak/flatpak/releases/tag/1.2.3
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00088.html
- https://access.redhat.com/errata/RHSA-2019:0375
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=922059
- https://github.com/flatpak/flatpak/releases/tag/1.0.7
- https://github.com/flatpak/flatpak/releases/tag/1.2.3
Get alerted when CVE-2019-8308 or the next vulnerability affects your stack