What’s Vulnerable › Vulnerabilities
CVE-2019-8425
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-02-18 · updated 2026-06-17
- Weakness: CWE-79
Description
includes/database.php in ZoneMinder before 1.32.3 has XSS in the construction of SQL-ERR messages.
Affected products
- zoneminder: before 1.32.3 — fixed in 1.32.3
How to fix
Upgrade to a fixed version: zoneminder 1.32.3. Check the vendor advisory for mitigations.
References
- https://github.com/LoRexxar/CVE_Request/tree/master/zoneminder%20vul%20before%20v1.32.3#sql-query-error-reflected-xss
- https://www.seebug.org/vuldb/ssvid-97764
- https://github.com/LoRexxar/CVE_Request/tree/master/zoneminder%20vul%20before%20v1.32.3#sql-query-error-reflected-xss
- https://www.seebug.org/vuldb/ssvid-97764
Get alerted when CVE-2019-8425 or the next vulnerability affects your stack