What’s Vulnerable › Vulnerabilities
CVE-2019-8427
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-02-18 · updated 2026-06-17
- Weakness: CWE-78
Description
daemonControl in includes/functions.php in ZoneMinder before 1.32.3 allows command injection via shell metacharacters.
Affected products
- zoneminder: before 1.32.3 — fixed in 1.32.3
How to fix
Upgrade to a fixed version: zoneminder 1.32.3. Check the vendor advisory for mitigations.
References
- https://github.com/LoRexxar/CVE_Request/tree/master/zoneminder%20vul%20before%20v1.32.3#includesfunctionsphp-daemoncontrol-command-injection
- https://github.com/LoRexxar/CVE_Request/tree/master/zoneminder%20vul%20before%20v1.32.3#includesfunctionsphp-daemoncontrol-command-injection
Get alerted when CVE-2019-8427 or the next vulnerability affects your stack