What’s Vulnerable › Vulnerabilities
CVE-2019-8509
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-10-27 · updated 2026-06-17
Description
This issue was addressed by removing the vulnerable code. This issue is fixed in macOS Catalina 10.15.1, Security Update 2019-001, and Security Update 2019-006, macOS Catalina 10.15. A malicious application may be able to elevate privileges.
Affected products
- macOS: from 10.13.6 before 10.15.1 — fixed in 10.15.1
How to fix
Upgrade to a fixed version: macOS 10.15.1. Check the vendor advisory for mitigations.
References
- https://support.apple.com/en-us/HT210634
- https://support.apple.com/en-us/HT210722
- https://support.apple.com/en-us/HT210634
- https://support.apple.com/en-us/HT210722
Get alerted when CVE-2019-8509 or the next vulnerability affects your stack