What’s Vulnerable › Vulnerabilities
CVE-2019-8720: WebKitGTK Memory Corruption Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-05-23
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-06 · updated 2026-10-08
- Weakness: CWE-119
Description
A vulnerability was found in WebKit. The flaw is triggered when processing maliciously crafted web content that may lead to arbitrary code execution. Improved memory handling addresses the multiple memory corruption issues.
Affected products
- RedHat Codeready Linux Builder: 8.0
- RedHat Codeready Linux Builder Eus: 8.4, 8.6
- RedHat Codeready Linux Builder For Arm64 Eus: 8.0, 8.4, 8.6
- RedHat Codeready Linux Builder For Ibm Z Systems Eus: 8.0, 8.4, 8.6
- RedHat Codeready Linux Builder For Power Little Endian Eus: 8.0, 8.4, 8.6
- Red Hat Enterprise Linux: 8.0
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Eus: 8.4, 8.6
- RedHat Enterprise Linux For Arm64 Eus: 8.6
- RedHat Enterprise Linux For Ibm Z Systems: 7.0, 8.0
- RedHat Enterprise Linux For Ibm Z Systems Eus: 8.4, 8.6
- RedHat Enterprise Linux For Power Big Endian: 7.0
- RedHat Enterprise Linux For Power Little Endian: 7.0, 8.0
- RedHat Enterprise Linux For Power Little Endian Eus: 8.4, 8.6
- RedHat Enterprise Linux For Scientific Computing: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 8.4, 8.6
- RedHat Enterprise Linux Server For Power Little Endian Update Services For Sap Solutions: 8.4, 8.6
- RedHat Enterprise Linux Server Tus: 8.4, 8.6
- RedHat Enterprise Linux Server Update Services For Sap Solutions: 8.4, 8.6
- RedHat Enterprise Linux Workstation: 7.0
- Webkit: before 2.26.0 — fixed in 2.26.0
- Wpewebkit Wpe Webkit: before 2.26.0 — fixed in 2.26.0
How to fix
Upgrade to a fixed version: Webkit 2.26.0; Wpewebkit Wpe Webkit 2.26.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1876611
- https://webkitgtk.org/security/WSA-2019-0005.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1876611
- https://webkitgtk.org/security/WSA-2019-0005.html
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2019-8720
Get alerted when CVE-2019-8720 or the next vulnerability affects your stack