What’s Vulnerable › Vulnerabilities
CVE-2019-8722
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-18 · updated 2026-06-17
- Weakness: CWE-20
Description
Multiple issues in ld64 in the Xcode toolchains were addressed by updating to version ld64-507.4. This issue is fixed in Xcode 11.0. Compiling code without proper input validation could lead to arbitrary code execution with user privilege.
Affected products
- Apple Xcode: before 11.0 — fixed in 11.0
How to fix
Upgrade to a fixed version: Apple Xcode 11.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-8722 or the next vulnerability affects your stack