What’s Vulnerable › Vulnerabilities
CVE-2019-8953
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 52.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-02-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The HAProxy package before 0.59_16 for pfSense has XSS via the desc (aka Description) or table_actionsaclN parameter, related to haproxy_listeners.php and haproxy_listeners_edit.php.
Affected products
- Netgate Haproxy: before 0.59_16 — fixed in 0.59_16
How to fix
Upgrade to a fixed version: Netgate Haproxy 0.59_16. Check the vendor advisory for mitigations.
References
- https://cxsecurity.com/issue/WLB-2019020153
- https://github.com/pfsense/FreeBSD-ports/commit/2dded47b3202dfdf89aa96f84bf701b3d5acbe6c
- https://github.com/pfsense/FreeBSD-ports/commit/3b40366aca55910b224ecf49d3fdacc9ad6c04f5
- https://redmine.pfsense.org/issues/9335
- https://www.exploit-db.com/exploits/46538/
- https://cxsecurity.com/issue/WLB-2019020153
- https://github.com/pfsense/FreeBSD-ports/commit/2dded47b3202dfdf89aa96f84bf701b3d5acbe6c
- https://github.com/pfsense/FreeBSD-ports/commit/3b40366aca55910b224ecf49d3fdacc9ad6c04f5
- https://redmine.pfsense.org/issues/9335
- https://www.exploit-db.com/exploits/46538/
Get alerted when CVE-2019-8953 or the next vulnerability affects your stack