What’s Vulnerable › Vulnerabilities
CVE-2019-8956
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-01 · updated 2026-06-17
- Weakness: CWE-416
Description
In the Linux Kernel before versions 4.20.8 and 4.19.21 a use-after-free error in the "sctp_sendmsg()" function (net/sctp/socket.c) when handling SCTP_SENDALL flag can be exploited to corrupt memory.
Affected products
- Canonical Ubuntu Linux: 18.04, 18.10
- Linux kernel: from 4.17 before 4.19.21; from 4.20 before 4.20.8 — fixed in 4.19.21, 4.20.8
How to fix
Upgrade to a fixed version: Linux kernel 4.19.21, 4.20.8. Check the vendor advisory for mitigations.
References
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.19.21
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.20.8
- https://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/commit/?id=ba59fb0273076637f0add4311faa990a5eec27c0
- https://secuniaresearch.flexerasoftware.com/secunia_research/2019-5/
- https://support.f5.com/csp/article/K12671141
- https://usn.ubuntu.com/3930-1/
- https://usn.ubuntu.com/3930-2/
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.19.21
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.20.8
- https://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/commit/?id=ba59fb0273076637f0add4311faa990a5eec27c0
- https://secuniaresearch.flexerasoftware.com/secunia_research/2019-5/
- https://support.f5.com/csp/article/K12671141
Get alerted when CVE-2019-8956 or the next vulnerability affects your stack