What’s Vulnerable › Vulnerabilities
CVE-2019-8980
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-02-21 · updated 2026-06-17
- Weakness: CWE-401
Description
A memory leak in the kernel_read_file function in fs/exec.c in the Linux kernel through 4.20.11 allows attackers to cause a denial of service (memory consumption) by triggering vfs_read failures.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Debian Linux: 8.0
- Linux kernel: from 4.7 before 4.9.163; from 4.14 before 4.14.106; from 4.19 before 4.19.28; from 4.20 before 4.20.15; from 5.0 before 5.0.1; 5.1-rc1 — fixed in 4.14.106, 4.19.28, 4.20.15, 4.9.163, 5.0.1
- openSUSE Leap: 15.0
How to fix
Upgrade to a fixed version: Linux kernel 4.14.106, 4.19.28, 4.20.15, 4.9.163. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00052.html
- http://www.securityfocus.com/bid/107120
- https://lists.debian.org/debian-lts-announce/2019/05/msg00002.html
- https://support.f5.com/csp/article/K56480726
- https://usn.ubuntu.com/3930-1/
- https://usn.ubuntu.com/3930-2/
- https://usn.ubuntu.com/3931-1/
- https://usn.ubuntu.com/3931-2/
- https://www.mail-archive.com/linux-kernel%40vger.kernel.org/msg1935698.html
- https://www.mail-archive.com/linux-kernel%40vger.kernel.org/msg1935705.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00052.html
- http://www.securityfocus.com/bid/107120
Get alerted when CVE-2019-8980 or the next vulnerability affects your stack