What’s Vulnerable › Vulnerabilities
CVE-2019-9003
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-02-22 · updated 2026-06-17
- Weakness: CWE-416
Description
In the Linux kernel before 4.20.5, attackers can trigger a drivers/char/ipmi/ipmi_msghandler.c use-after-free and OOPS by arranging for certain simultaneous execution of the code, as demonstrated by a "service ipmievd restart" loop.
Affected products
- Canonical Ubuntu Linux: 18.04, 18.10
- Linux kernel: from 4.18 before 4.19.18; from 4.20 before 4.20.5; 5.0-rc1, 5.0-rc2, 5.0-rc3, 5.0-rc4 — fixed in 4.19.18, 4.20.5
- NetApp Cn1610 Firmware: all versions
- NetApp Hci Management Node: all versions
- NetApp Snapprotect: all versions
- NetApp Solidfire: all versions
- openSUSE Leap: 15.0
How to fix
Upgrade to a fixed version: Linux kernel 4.19.18, 4.20.5. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=77f8269606bf95fcb232ee86f6da80886f1dfae8
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00037.html
- http://www.securityfocus.com/bid/107145
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.20.5
- https://github.com/torvalds/linux/commit/77f8269606bf95fcb232ee86f6da80886f1dfae8
- https://security.netapp.com/advisory/ntap-20190327-0002/
- https://usn.ubuntu.com/3930-1/
- https://usn.ubuntu.com/3930-2/
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=77f8269606bf95fcb232ee86f6da80886f1dfae8
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00037.html
- http://www.securityfocus.com/bid/107145
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.20.5
Get alerted when CVE-2019-9003 or the next vulnerability affects your stack