What’s Vulnerable › Vulnerabilities
CVE-2019-9011
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-26 · updated 2026-06-17
- Weakness: CWE-668
Description
In Pilz PMC programming tool 3.x before 3.5.17 (based on CODESYS Development System), an attacker can identify valid usernames.
Affected products
- PILZ Pmc: from 3.0.0 before 3.5.17 — fixed in 3.5.17
How to fix
Upgrade to a fixed version: PILZ Pmc 3.5.17. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-9011 or the next vulnerability affects your stack