What’s Vulnerable › Vulnerabilities

CVE-2019-9020

Description

An issue was discovered in PHP before 5.6.40, 7.x before 7.1.26, 7.2.x before 7.2.14, and 7.3.x before 7.3.1. Invalid input to the function xmlrpc_decode() can lead to an invalid memory access (heap out of bounds read or read after free). This is related to xml_elem_parse_buf in ext/xmlrpc/libxmlrpc/xml_element.c.

Affected products

How to fix

Upgrade to a fixed version: PHP 5.6.40, 7.1.26, 7.2.14, 7.3.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-9020 or the next vulnerability affects your stack