What’s Vulnerable › Vulnerabilities
CVE-2019-9022
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-02-22 · updated 2026-06-17
- Weakness: CWE-125
Description
An issue was discovered in PHP 7.x before 7.1.26, 7.2.x before 7.2.14, and 7.3.x before 7.3.2. dns_get_record misparses a DNS response, which can allow a hostile DNS server to cause PHP to misuse memcpy, leading to read operations going past the buffer allocated for DNS data. This affects php_parserr in ext/standard/dns.c for DNS_CAA and DNS_ANY queries.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04
- Debian Linux: 8.0, 9.0
- NetApp Storage Automation Store: all versions
- PHP: from 7.0.0 before 7.1.26; from 7.2.0 before 7.2.14; from 7.3.0 before 7.3.2 — fixed in 7.1.26, 7.2.14, 7.3.2
How to fix
Upgrade to a fixed version: PHP 7.1.26, 7.2.14, 7.3.2. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00041.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00044.html
- https://access.redhat.com/errata/RHSA-2019:2519
- https://access.redhat.com/errata/RHSA-2019:3299
- https://bugs.php.net/bug.php?id=77369
- https://lists.debian.org/debian-lts-announce/2019/03/msg00043.html
- https://security.netapp.com/advisory/ntap-20190321-0001/
- https://usn.ubuntu.com/3902-1/
- https://usn.ubuntu.com/3922-2/
- https://usn.ubuntu.com/3922-3/
- https://www.debian.org/security/2019/dsa-4398
- https://www.tenable.com/security/tns-2019-07
Get alerted when CVE-2019-9022 or the next vulnerability affects your stack