What’s Vulnerable › Vulnerabilities
CVE-2019-9023
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-02-22 · updated 2026-06-17
- Weakness: CWE-125
Description
An issue was discovered in PHP before 5.6.40, 7.x before 7.1.26, 7.2.x before 7.2.14, and 7.3.x before 7.3.1. A number of heap-based buffer over-read instances are present in mbstring regular expression functions when supplied with invalid multibyte data. These occur in ext/mbstring/oniguruma/regcomp.c, ext/mbstring/oniguruma/regexec.c, ext/mbstring/oniguruma/regparse.c, ext/mbstring/oniguruma/enc/unicode.c, and ext/mbstring/oniguruma/src/utf32_be.c when a multibyte regular expression pattern contains invalid multibyte sequences.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04
- Debian Linux: 9.0
- NetApp Storage Automation Store: all versions
- openSUSE Leap: 42.3
- PHP: before 5.6.40; from 7.0.0 before 7.1.26; from 7.2.0 before 7.2.14; from 7.3.0 before 7.3.1 — fixed in 5.6.40, 7.1.26, 7.2.14, 7.3.1
How to fix
Upgrade to a fixed version: PHP 5.6.40, 7.1.26, 7.2.14, 7.3.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00083.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00104.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00041.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00044.html
- http://www.securityfocus.com/bid/107156
- https://access.redhat.com/errata/RHSA-2019:2519
- https://access.redhat.com/errata/RHSA-2019:3299
- https://bugs.php.net/bug.php?id=77370
- https://bugs.php.net/bug.php?id=77371
- https://bugs.php.net/bug.php?id=77381
- https://bugs.php.net/bug.php?id=77382
- https://bugs.php.net/bug.php?id=77385
Get alerted when CVE-2019-9023 or the next vulnerability affects your stack