What’s Vulnerable › Vulnerabilities
CVE-2019-9024
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-02-22 · updated 2026-06-17
- Weakness: CWE-125
Description
An issue was discovered in PHP before 5.6.40, 7.x before 7.1.26, 7.2.x before 7.2.14, and 7.3.x before 7.3.1. xmlrpc_decode() can allow a hostile XMLRPC server to cause PHP to read memory outside of allocated areas in base64_decode_xmlrpc in ext/xmlrpc/libxmlrpc/base64.c.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04
- Debian Linux: 9.0
- NetApp Storage Automation Store: all versions
- openSUSE Leap: 42.3
- PHP: before 5.6.40; from 7.0.0 before 7.1.26; from 7.2.0 before 7.2.14; from 7.3.0 before 7.3.1 — fixed in 5.6.40, 7.1.26, 7.2.14, 7.3.1
How to fix
Upgrade to a fixed version: PHP 5.6.40, 7.1.26, 7.2.14, 7.3.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00083.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00104.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00041.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00044.html
- http://www.securityfocus.com/bid/107156
- https://access.redhat.com/errata/RHSA-2019:2519
- https://access.redhat.com/errata/RHSA-2019:3299
- https://bugs.php.net/bug.php?id=77380
- https://security.netapp.com/advisory/ntap-20190321-0001/
- https://usn.ubuntu.com/3902-1/
- https://usn.ubuntu.com/3902-2/
- https://www.debian.org/security/2019/dsa-4398
Get alerted when CVE-2019-9024 or the next vulnerability affects your stack