What’s Vulnerable › Vulnerabilities
CVE-2019-9085
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-06-24 · updated 2026-06-17
- Weakness: CWE-20
Description
Hoteldruid before v2.3.1 allows remote authenticated users to cause a denial of service (invoice-creation outage) via the n_file parameter to visualizza_contratto.php with invalid arguments (any non-numeric value), as demonstrated by the anno=2019&id_transazione=1&numero_contratto=1&n_file=a query string to visualizza_contratto.php.
Affected products
- DigitalDruid.Net HOTELDRUID: before 2.3.1 — fixed in 2.3.1
How to fix
Upgrade to a fixed version: DigitalDruid.Net HOTELDRUID 2.3.1. Check the vendor advisory for mitigations.
References
- http://www.hoteldruid.com/en/download.html
- https://metamorfosec.com/Files/Advisories/METS-2019-006-An_Invalid_Arguments_in_Hoteldruid_before_v2.3.1.txt
- http://www.hoteldruid.com/en/download.html
- https://metamorfosec.com/Files/Advisories/METS-2019-006-An_Invalid_Arguments_in_Hoteldruid_before_v2.3.1.txt
Get alerted when CVE-2019-9085 or the next vulnerability affects your stack