What’s Vulnerable › Vulnerabilities
CVE-2019-9115
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-02-25 · updated 2026-06-17
- Weakness: CWE-94
Description
In irisnet-crypto before 1.1.7 for IRISnet, the util/utils.js file allows code execution because of unsafe eval usage.
Affected products
- Irisnet-Crypto: before 1.1.7 — fixed in 1.1.7
How to fix
Upgrade to a fixed version: Irisnet-Crypto 1.1.7. Check the vendor advisory for mitigations.
References
- https://github.com/irisnet/irisnet-crypto/issues/60
- https://github.com/irisnet/irisnet-crypto/issues/60
Get alerted when CVE-2019-9115 or the next vulnerability affects your stack