What’s Vulnerable › Vulnerabilities
CVE-2019-9162
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-02-25 · updated 2026-06-17
- Weakness: CWE-787
Description
In the Linux kernel before 4.20.12, net/ipv4/netfilter/nf_nat_snmp_basic_main.c in the SNMP NAT module has insufficient ASN.1 length checks (aka an array index error), making out-of-bounds read and write operations possible, leading to an OOPS or local privilege escalation. This affects snmp_version and snmp_helper.
Affected products
- Canonical Ubuntu Linux: 18.04, 18.10
- Linux kernel: from 4.19 before 4.19.25; from 4.20 before 4.20.12 — fixed in 4.19.25, 4.20.12
- NetApp Cn1610 Firmware: all versions
- NetApp Hci Management Node: all versions
- NetApp Snapprotect: all versions
- NetApp Solidfire: all versions
How to fix
Upgrade to a fixed version: Linux kernel 4.19.25, 4.20.12. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=c4c07b4d6fa1f11880eab8e076d3d060ef3f55fc
- http://www.securityfocus.com/bid/107159
- https://bugs.chromium.org/p/project-zero/issues/detail?id=1776
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.19.25
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.20.12
- https://github.com/torvalds/linux/commit/c4c07b4d6fa1f11880eab8e076d3d060ef3f55fc
- https://security.netapp.com/advisory/ntap-20190327-0002/
- https://support.f5.com/csp/article/K31864522
- https://usn.ubuntu.com/3930-1/
- https://usn.ubuntu.com/3930-2/
- https://www.exploit-db.com/exploits/46477/
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=c4c07b4d6fa1f11880eab8e076d3d060ef3f55fc
Get alerted when CVE-2019-9162 or the next vulnerability affects your stack