What’s Vulnerable › Vulnerabilities
CVE-2019-9169
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-02-26 · updated 2026-10-14
- Weakness: CWE-125
Description
In the GNU C Library (aka glibc or libc6) through 2.29, proceed_next_node in posix/regexec.c has a heap-based buffer over-read via an attempted case-insensitive regular-expression match.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.10
- GNU C Library (glibc): through 2.29
- McAfee Web Gateway (MWG): from 7.7.2.0 before 7.7.2.21; from 7.8.2.0 before 7.8.2.8; from 8.0.0 before 8.1.1 — fixed in 7.7.2.21, 7.8.2.8, 8.1.1
- NetApp Cloud Backup: all versions
- NetApp ONTAP Select Deploy administration utility: all versions
- NetApp Steelstore Cloud Integrated Storage: all versions
How to fix
Upgrade to a fixed version: McAfee Web Gateway (MWG) 7.7.2.21, 7.8.2.8, 8.1.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107160
- https://debbugs.gnu.org/cgi/bugreport.cgi?bug=34140
- https://debbugs.gnu.org/cgi/bugreport.cgi?bug=34142
- https://kc.mcafee.com/corporate/index?page=content&id=SB10278
- https://security.gentoo.org/glsa/202006-04
- https://security.netapp.com/advisory/ntap-20190315-0002/
- https://sourceware.org/bugzilla/show_bug.cgi?id=24114
- https://sourceware.org/git/gitweb.cgi?p=glibc.git%3Ba=commit%3Bh=583dd860d5b833037175247230a328f0050dbfe9
- https://support.f5.com/csp/article/K54823184
- https://usn.ubuntu.com/4416-1/
- https://www.oracle.com/security-alerts/cpuapr2022.html
- http://www.securityfocus.com/bid/107160
Get alerted when CVE-2019-9169 or the next vulnerability affects your stack