What’s Vulnerable › Vulnerabilities
CVE-2019-9184
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-02-26 · updated 2026-06-17
- Weakness: CWE-89
Description
SQL injection vulnerability in the J2Store plugin 3.x before 3.3.7 for Joomla! allows remote attackers to execute arbitrary SQL commands via the product_option[] parameter.
Affected products
- J2Store: from 3.3.0 before 3.3.7 — fixed in 3.3.7
How to fix
Upgrade to a fixed version: J2Store 3.3.7. Check the vendor advisory for mitigations.
References
- https://andreiconache.me/j2store-plugin-3-3-6-sql-injection/
- https://www.exploit-db.com/exploits/46467/
- https://www.j2store.org/blog/general/security-update-for-j2store.html
- https://andreiconache.me/j2store-plugin-3-3-6-sql-injection/
- https://www.exploit-db.com/exploits/46467/
- https://www.j2store.org/blog/general/security-update-for-j2store.html
Get alerted when CVE-2019-9184 or the next vulnerability affects your stack