What’s Vulnerable › Vulnerabilities
CVE-2019-9187
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-06-05 · updated 2026-06-17
- Weakness: CWE-918
Description
ikiwiki before 3.20170111.1 and 3.2018x and 3.2019x before 3.20190228 allows SSRF via the aggregate plugin. The impact also includes reading local files via file: URIs.
Affected products
- ikiwiki: before 3.20170111.1; from 3.20190207 before 3.20190226; 3.20180105, 3.20180228, 3.20180311 — fixed in 3.20170111.1, 3.20190226
How to fix
Upgrade to a fixed version: ikiwiki 3.20170111.1, 3.20190226. Check the vendor advisory for mitigations.
References
- https://ikiwiki.info/news/
- https://ikiwiki.info/news/version_3.20190228/
- https://lists.debian.org/debian-lts-announce/2019/03/msg00018.html
- https://ikiwiki.info/news/
- https://ikiwiki.info/news/version_3.20190228/
- https://lists.debian.org/debian-lts-announce/2019/03/msg00018.html
Get alerted when CVE-2019-9187 or the next vulnerability affects your stack