What’s Vulnerable › Vulnerabilities
CVE-2019-9194
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 96.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-02-26 · updated 2026-06-17
- Weakness: CWE-78
Description
elFinder before 2.1.48 has a command injection vulnerability in the PHP connector.
Affected products
- Studio-42 elFinder: before 2.1.48 — fixed in 2.1.48
How to fix
Upgrade to a fixed version: Studio-42 elFinder 2.1.48. Check the vendor advisory for mitigations.
References
- https://github.com/Studio-42/elFinder/blob/master/README.md
- https://github.com/Studio-42/elFinder/compare/6884c4f...0740028
- https://github.com/Studio-42/elFinder/releases/tag/2.1.48
- https://www.exploit-db.com/exploits/46481/
- https://www.exploit-db.com/exploits/46539/
- https://github.com/Studio-42/elFinder/blob/master/README.md
- https://github.com/Studio-42/elFinder/compare/6884c4f...0740028
- https://github.com/Studio-42/elFinder/releases/tag/2.1.48
- https://www.exploit-db.com/exploits/46481/
- https://www.exploit-db.com/exploits/46539/
Get alerted when CVE-2019-9194 or the next vulnerability affects your stack