What’s Vulnerable › Vulnerabilities
CVE-2019-9213
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-03-05 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel before 4.20.14, expand_downwards in mm/mmap.c lacks a check for the mmap minimum address, which makes it easier for attackers to exploit kernel NULL pointer dereferences on non-SMAP platforms. This is related to a capability check for the wrong task.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.10
- Debian Linux: 8.0
- Linux kernel: from 4.9 before 4.9.162; from 4.14 before 4.14.105; from 4.19 before 4.19.27; from 4.20 before 4.20.14 — fixed in 4.14.105, 4.19.27, 4.20.14, 4.9.162
- openSUSE Leap: 15.0, 42.3
- Red Hat Enterprise Linux: 7.0, 8.0
How to fix
Upgrade to a fixed version: Linux kernel 4.14.105, 4.19.27, 4.20.14, 4.9.162. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=0a1d52994d440e21def1c2174932410b4f2a98a1
- http://lists.opensuse.org/opensuse-security-announce/2019-03/msg00045.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00052.html
- http://packetstormsecurity.com/files/156053/Reliable-Datagram-Sockets-RDS-rds_atomic_free_op-Privilege-Escalation.html
- http://www.securityfocus.com/bid/107296
- https://access.redhat.com/errata/RHSA-2019:0831
- https://access.redhat.com/errata/RHSA-2019:1479
- https://access.redhat.com/errata/RHSA-2019:1480
- https://bugs.chromium.org/p/project-zero/issues/detail?id=1792
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.14.105
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.19.27
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.20.14
Get alerted when CVE-2019-9213 or the next vulnerability affects your stack