What’s Vulnerable › Vulnerabilities
CVE-2019-9215
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-02-28 · updated 2026-06-17
Description
In Live555 before 2019.02.27, malformed headers lead to invalid memory access in the parseAuthorizationHeader function.
Affected products
- Debian Linux: 8.0, 9.0
- Live555 Streaming Media: before 2019.02.27 — fixed in 2019.02.27
- openSUSE Backports Sle: 15.0, 15.0-sp1
- openSUSE Leap: 15.0, 15.1, 15.2
How to fix
Upgrade to a fixed version: Live555 Streaming Media 2019.02.27. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00044.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00024.html
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00009.html
- http://www.live555.com/liveMedia/public/changelog.txt
- https://lists.debian.org/debian-lts-announce/2019/03/msg00022.html
- https://seclists.org/bugtraq/2019/Mar/22
- https://security.gentoo.org/glsa/202005-06
- https://www.debian.org/security/2019/dsa-4408
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00044.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00024.html
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00009.html
- http://www.live555.com/liveMedia/public/changelog.txt
Get alerted when CVE-2019-9215 or the next vulnerability affects your stack