What’s Vulnerable › Vulnerabilities
CVE-2019-9585
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-08-14 · updated 2026-06-17
- Weakness: CWE-306
Description
eQ-3 Homematic CCU2 prior to 2.47.10 and CCU3 prior to 3.47.10 JSON API has Improper Access Control for Interface.***Metadata related operations, resulting in the ability to read, set and deletion of Metadata.
Affected products
- Eq-3 Homematic Ccu2 Firmware: before 2.47.10 — fixed in 2.47.10
- Eq-3 Homematic Ccu3 Firmware: before 3.47.10 — fixed in 3.47.10
How to fix
Upgrade to a fixed version: Eq-3 Homematic Ccu2 Firmware 2.47.10; Eq-3 Homematic Ccu3 Firmware 3.47.10. Check the vendor advisory for mitigations.
References
- https://github.com/psytester/psytester.github.io/blob/master/_posts/hacking_and_pentests/CVEs/2019-03-27-CVE-2019-9585.md
- https://psytester.github.io/CVE-2019-9585/
- https://github.com/psytester/psytester.github.io/blob/master/_posts/hacking_and_pentests/CVEs/2019-03-27-CVE-2019-9585.md
- https://psytester.github.io/CVE-2019-9585/
Get alerted when CVE-2019-9585 or the next vulnerability affects your stack