What’s Vulnerable › Vulnerabilities
CVE-2019-9636
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-08 · updated 2026-10-14
- Weakness: CWE-173
Description
Python 2.7.x through 2.7.16 and 3.x through 3.7.2 is affected by: Improper Handling of Unicode Encoding (with an incorrect netloc) during NFKC normalization. The impact is: Information disclosure (credentials, cookies, etc. that are cached against a given hostname). The components are: urllib.parse.urlsplit, urllib.parse.urlparse. The attack vector is: A specially crafted URL could be incorrectly parsed to locate cookies or authentication data and send that information to a different host than when parsed correctly. This is fixed in: v2.7.17, v2.7.17rc1, v2.7.18, v2.7.18rc1; v3.5.10, v3.5.10rc1, v3.5.7, v3.5.8, v3.5.8rc1, v3.5.8rc2, v3.5.9; v3.6.10, v3.6.10rc1, v3.6.11, v3.6.11rc1, v3.6.12, v3.6.9, v3.6.9rc1; v3.7.3, v3.7.3rc1, v3.7.4, v3.7.4rc1, v3.7.4rc2, v3.7.5, v3.7.5rc1, v3.7.6, v3.7.6rc1, v3.7.7, v3.7.7rc1, v3.7.8, v3.7.8rc1, v3.7.9.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04, 19.04
- Debian Linux: 8.0, 9.0
- Fedoraproject Fedora: 28, 29, 30, 31
- openSUSE Leap: 15.0, 15.1, 42.3
- Oracle Corporation Sun ZFS Storage Appliance Kit (AK) Software: 8.8.6
- Python: from 2.7.0 before 2.7.17; from 3.0.0 before 3.4.10; from 3.5.0 before 3.5.7; from 3.6.0 before 3.6.9; from 3.7.0 before 3.7.3 — fixed in 2.7.17, 3.4.10, 3.5.7, 3.6.9, 3.7.3
- Red Hat Enterprise Linux: 7.5, 8.0
- RedHat Enterprise Linux Desktop: 6.0
- RedHat Enterprise Linux Eus: 7.5, 8.1, 8.2, 8.4, 8.6
- RedHat Enterprise Linux Server: 6.0
- RedHat Enterprise Linux Server Aus: 7.4, 8.2, 8.4
- RedHat Enterprise Linux Server Eus: 5.6
- RedHat Enterprise Linux Server Tus: 7.4, 8.2, 8.4, 8.6
- RedHat Enterprise Linux Workstation: 6.0
- Red Hat OpenShift Container Platform 4.18: 3.11
- RedHat Virtualization: 4.0
How to fix
Upgrade to a fixed version: Python 2.7.17, 3.4.10, 3.5.7, 3.6.9. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00092.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00097.html
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00024.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00050.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00042.html
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00040.html
- http://www.securityfocus.com/bid/107400
- https://access.redhat.com/errata/RHBA-2019:0763
- https://access.redhat.com/errata/RHBA-2019:0764
- https://access.redhat.com/errata/RHBA-2019:0959
- https://access.redhat.com/errata/RHSA-2019:0710
- https://access.redhat.com/errata/RHSA-2019:0765
Get alerted when CVE-2019-9636 or the next vulnerability affects your stack